1. 1C / Говнокод #25465

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    Набор = РегистрыСведений.ЗначенияСвойствОбъектов.СоздатьНаборЗаписей();
    		Отбор = Набор.Отбор;
    		Отбор.Объект.Использование = Истина;
    		Отбор.Объект.ВидСравнения = ВидСравнения.Равно;
    		Отбор.Свойство.ВидСравнения = ВидСравнения.Равно;
    		Отбор.Объект.Значение = Грузополучатель;                
    		Отбор.Свойство.Значение = ПланыВидовХарактеристик.СвойстваОбъектов.НайтиПоНаименованию("GLN").Ссылка;
    		Набор.Прочитать();
    		GLN_получ = "";
    		Если Набор.Количество() > 0 Тогда
    			Для нумер = 0 по Набор.Количество()-1 Цикл
    				Свво = Набор.Получить(нумер).Свойство;
    				Если СокрЛП(Свво.Наименование) = "GLN" Тогда
    					GLN_получ = Набор.Получить(нумер).Значение;
    				КонецЕсли;
    			КонецЦикла;
    		КонецЕсли;
    
    		ОбластьМакета.Параметры.GLN_получ       = GLN_получ;

    cdpoma, 22 Марта 2019

    Комментарии (16)
  2. 1C / Говнокод #25406

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    СтраницыПанели = ЭтаФорма.ЭлементыФормы.ОсновнаяПанель.Страницы;
    Для Каждого Страница Bз СтраницыПанели Цикл
    	Если ПакетныйВводКонтрагентов = Истина Тогда
    		Если Страница.Имя = "стрКонтрагенты" Тогда
    			Страница.Доступность = Истина;
    		КонецЕсли;
    	КонецЕсли;
    КонецЦикла;

    kvvit74, 25 Февраля 2019

    Комментарии (1)
  3. 1C / Говнокод #25388

    +2

    1. 1
    Мес = ?(Месяц(ДатаДок) > 9 ,Строка(Месяц(ДатаДок)) ,"0"+ Строка(Месяц(ДатаДок)));

    Формат(ДатаДок, "ДФ=MM") придуман для неудачников!

    Migelek, 19 Февраля 2019

    Комментарии (5)
  4. 1C / Говнокод #25336

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    ВЫБРАТЬ
    КОЛИЧЕСТВО ( РАЗЛИЧНЫЕ УвольнениеИзОрганизации.Сотрудник) КАК Сотрудник
    Кадровая история сотрудников спецслужб их.Подразделение,
    ЕСТЬNULL (КОЛИЧЕСТВО ( РАЗЛИЧНЫЕ ВЫБОР
    КОГДА УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование = "" По собой желанию, на учебу пункт 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию, по уходу за инвалидном п.3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование = "" По соб желанию, ребёнок-инвалид до 18 л., А 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию , с переменой м. ж.,  пункт 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию, по уходу за ребенком до 14 лет, п 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию , на пенсию, п 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" по соб желанию, п.3 статьи 77 ТК РФ""
    ТОГДА УвольнениеИзОрганизаций.Сотрудник
    КОНЕЦ ), 0) КАК увПоСобств,
     ЕСТЬNULL (ВЫБОР
     
    КОГДА УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" За прогулы, подпункт """" а"""" пункта 6 статьи 81 ТК РФ""
    ТОГДА УвольнениеИзОрганизаций.Сотрудник
    КОНЕЦ ,0) КАК УвПрогул,
    ЕСТЬNULL ( КОЛИЧЕСТВО ( РАЗЛИЧНЫЕ УвольнениеИзОрганизации.Сотрудник
    ),0) Как УвВсего
    ИЗ Документ.Увольнение.Сотрудник КАК УвольнениеИзОрганизации
    ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.КадроваяИсторияСотрудников.СрезПоследних как КадроваяИсторияСотрудниковСрезПоследних
    ПО Сотрудник КАК УвольнениеИзОрганизации.Сотрудник = КадроваяИсторияСотрудниковСрезПоследних.Сотрудник 
    ГДЕ 
    УвольнениеИзОрганизации.Ссылка.Организации в ИЕРАРХИИ (& Организация)
    И УвольнениеИзОрганизации.ДатаУвольнения >=& НачалоГода
     И (УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию, по уходу за инвалидном п.3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование = "" По соб желанию, ребёнок-инвалид до 18 л., А 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию , с переменой м. ж.,  пункт 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию, по уходу за ребенком до 14 лет, п 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" По соб желанию , на пенсию, п 3 статьи 77 ТК РФ""
    ИЛИ УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" по соб желанию, п.3 статьи 77 ТК РФ""
    ИЛИ  УвольнениеИзОрганизаций.СтатьяТКРФ.Наименование ="" За прогулы, подпункт """" а"""" пункта 6 статьи 81 ТК РФ""
    ) 
    СГРУППИРОВАТЬ ПО
    КадроваяИсторияСотрудниковСрезПоследних.Подразлеление
    ЕСТЬNULL (ВЫБОР 
    КОГДА Увольнение Зоран зайти.СтатьяТКРФ.Наименование = "" За прогулы, подпункт """" а"""" пункта 6 статьи 81 ТК РФ""
    ТОГДА УвольнениеИзОрганизации.Сотрудник 
    КОНЕЦ ,0);

    Зачем ему конфигуратор? Он и так может отчеты выводить в табДок через блокнот)))
    Ссылка на источник ТУТ - http://www.cyberforum.ru/1c/thread2394049.html

    dethmontt, 29 Января 2019

    Комментарии (39)
  5. 1C / Говнокод #25322

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    // Проверим необходимость проведения авторизаций безналичных платежей
    	АвторизацийБПЕсть = НЕ (НетОплатПлатежнойКартой()
    	Если АвторизацийБПЕсть Тогда
    		// Выполняем авторизации безналичных платежей
    		Если НЕ ВыполнитьАвторизациюБП() Тогда
    .....
    
    
    
    Функция НетОплатПлатежнойКартой()
    
    	НетОплатПлатежнойКартой = Истина;
    	Для Каждого СтрокаОплаты Из Оплаты Цикл
    		Если СтрокаОплаты.ТипОплаты.Объект = Перечисления.ТипыОплатыВРознице.Безналичные Тогда
    			НетОплатПлатежнойКартой = Ложь;
    			Прервать;
    		КонецЕсли;
    	КонецЦикла;
    
    	Возврат НетОплатПлатежнойКартой;
    
    КонецФункции

    Нужно больше инверсий!

    Jtsuken, 23 Января 2019

    Комментарии (5)
  6. 1C / Говнокод #25301

    +4

    1. 1
    2. 2
    3. 3
    Если ЭтаФорма.ВладелецФормы.ВладелецФормы.Объект.Заголовок = "Согласование контрагента " Или ЭтаФорма.ВладелецФормы.ВладелецФормы.Объект.Заголовок = "" Тогда
                 ЭтаФорма.ВладелецФормы.ВладелецФормы.Объект.Заголовок = "Согласование контрагента " + КонтрагентДО;
    КонецЕсли;

    Просто оставлю это здесь.
    Когда ж вы все передохните любители ВладельцевФормы через ВладельцаФормы.

    MaxBS, 11 Января 2019

    Комментарии (4)
  7. 1C / Говнокод #25300

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    Функция ИдентификаторЦепочки(Ссылка) Экспорт
    	
    	Результат = Документы.ЭтапПроизводства2_2.ПустаяСсылка();
    	
    	Запрос = Новый Запрос(
    	"ВЫБРАТЬ
    	|	Таблица.ИдентификаторЦепочки КАК ИдентификаторЦепочки
    	|ИЗ
    	|	Документ.ЭтапПроизводства2_2 КАК Таблица
    	|ГДЕ
    	|	Таблица.Ссылка = &Ссылка");
    	Запрос.УстановитьПараметр("Ссылка", Ссылка);
    	
    	Выборка = Запрос.Выполнить().Выбрать();
    	
    	Если Выборка.Следующий() Тогда
    		
    		Результат = Выборка.ИдентификаторЦепочки;
    		
    	КонецЕсли;
    	
    	Возврат Результат;
    	
    КонецФункции

    Функция из типовой, возвращает реквизит документа через жопу. Можно заменить на
    возврат ?(ЗначениеЗаполнено(Ссылка.Идентификатор Цепочки), Ссылка.ИдентификаторЦепочки, Документы.ЭтапПроизводства2_2.ПустаяСсыл ка()).
    А можно вообще нихуя не делать, потому что если реквизит не заполнен, там и так пустая ссылка.
    Нахуй так жить

    acula98, 11 Января 2019

    Комментарии (5)
  8. 1C / Говнокод #25236

    0

    1. 1
    Сумма = Цел(Окр(Сумма * 1000, 0, 1)) / 1000;

    Или я мандаринов переел, или от этого портал должен открыться

    valchara, 27 Декабря 2018

    Комментарии (42)
  9. 1C / Говнокод #25211

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    СообщениеСМС = Перечисления.СостоянияСообщенияSMS.Исходящее;
    		Для каждого СообщениеСМС Из СообщениеSMS.Услуги Цикл
    			СообщениеСМС.СостояниеСообщения = Перечисления.СостоянияСообщенияSMS.Исходящее;
    		КонецЦикла;

    1С:Медицина. Поликлинка

    gk-5ccd112a, 21 Декабря 2018

    Комментарии (4)
  10. 1C / Говнокод #25210

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    ТекЧас = Строка(Час(Дата2));
    ТекЧас = Прав("00" + ТекЧас, 2);
    ТекМин = Строка(Минута(Дата2));
    ТекМин = Прав("00" + ТекМин, 2);
    ТекВремя = ТекЧас + ":" + ТекМин;

    Это способ получить время в формате "чч:мм" из даты и времени (переменная Дата2).
    Заменяется этим:
    ТекВремя = Формат(Дата2, "ДФ=hh:mm");

    VladC, 21 Декабря 2018

    Комментарии (4)