1. 1C / Говнокод #27064

    +5

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    Функция РазрешеноМенятьЗаявкуПоПравилу9Утра()    
    	
     	_Год    = Год  ( Объект.Дата);
    	_Месяц  = Месяц( Объект.Дата);
    	_День   = День ( Объект.Дата) + 1;
    	
    	Если _День = 29 Тогда
    		Если _Месяц = 2 Тогда
    			
    			Если (_Год - 2016)%4 <> 0 Тогда	
    				
    				_Месяц = 3; _День = 1;
    			КонецЕсли;  
    		КонецЕсли;
    	КонецЕсли;
    	
    	Если _День = 30 Тогда
    		Если (_Месяц = 4) ИЛИ (_Месяц = 6) ИЛИ (_Месяц = 9) ИЛИ (_Месяц = 11) Тогда
    			
    			_Месяц = _Месяц + 1;
    			_День  = 1;
    		КонецЕсли;
    	КонецЕсли;
    	
    	Если _День = 31 Тогда
    		Если (_Месяц = 1) ИЛИ (_Месяц = 3) ИЛИ (_Месяц = 5) ИЛИ (_Месяц = 7) ИЛИ
    			(_Месяц = 8)        Тогда
    			
    			_Месяц = _Месяц + 1;
    			_День  = 1;
    		ИначеЕсли _Месяц = 12  Тогда
    			
    			_Месяц = 1;
    			_День  = 1; 
    		КонецЕсли;
    	КонецЕсли;
    	
    	_9УтраСледующегоДня = Дата( _Год , _Месяц, _День,9,0,0);
    	
    	Если ТекущаяДата() < _9УтраСледующегоДня Тогда
    		
    		Возврат Истина;
    	Иначе
    		
    		Возврат Ложь;
    	КонецЕсли;
    	  
    КонецФункции

    По-моему, достойно Вашего внимания ;)

    ShilkovNikolay, 27 Октября 2020

    Комментарии (42)
  2. 1C / Говнокод #27048

    −1

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    Функция ВнешнийОтчетВФоновомЗадании(НаимРеглОтч)
    	...
    		ИмяОбработки = ВнешниеОтчеты.Подключить(АдресВоВременномХранилище, , Ложь);
    		Возврат ВнешниеОтчеты.Создать(ИмяОбработки, Истина);
    	...
    КонецФункции

    В фоновом задании создаем внешний отчет с БезопасныйРежим=Истина. Вопрос, типа, "предупреждение безопасности, разрешить открывать данный файл?", конечно, никому не выходит. Итог для пользователя - ошибка. Что за звездец! Как можно задавать вопрос в фоновом? Зачем? ЗУП 3.1 типовая

    sandvich, 22 Октября 2020

    Комментарии (8)
  3. 1C / Говнокод #27037

    0

    1. 1
    2. 2
    3. 3
    4. 4
    Если Число(Сред(Строка(НачПериода),4,2)) <> Число(Сред(Строка(КонПериода),4,2)) Тогда
    	Предупреждение("Нельзя брать период с разными месяцами!!!");
    	Возврат;
    КонецЕсли;

    Мне так не дано писать код :-)

    Asinto, 17 Октября 2020

    Комментарии (4)
  4. 1C / Говнокод #27024

    0

    1. 1
    2. 2
    3. 3
    Если Ложь Тогда
    	Объ = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();	
    КонецЕсли;

    Умиляет

    sandvich, 13 Октября 2020

    Комментарии (20)
  5. 1C / Говнокод #26998

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    ДанныеКальлулятора = ПолучитьДанныеКалькулятораПоЗаявке(Заявка);
    	Расчет = ДанныеКальлулятора["ТЧ.Расчет"].Скопировать();
    	
    	ОстаточнаяПроцент = ДанныеКальлулятора["впОстаточнаяСтоимость"];
    	ПроцентнаяСтавка = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["рпСтоимостьКапитала"];
    	СрокЛизингаСтарыйИзКалькулятора = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["впСрокЛизинга"];
    	
    	ГибридСтавкаФинансированияКапитальнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридСтавкаФинансированияКапитальнаяЧасть"];
    	ГибридСтавкаФинансированияОстаточнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридСтавкаФинансированияОстаточнаяЧасть"];
    	ГибридФианансоваяМаржаКапитальнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридФианансоваяМаржаКапитальнаяЧасть"];
    	ГибридФианансоваяМаржаОстаточнаяЧасть = ПолучитьДанныеКалькулятораПоЗаявке(Заявка)["ГибридФианансоваяМаржаОстаточнаяЧасть"];

    Как ж бомбит. Отраслёвка лизинговая

    sandvich, 02 Октября 2020

    Комментарии (7)
  6. 1C / Говнокод #26997

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    ЗапросШК.Текст = "ВЫБРАТЬ
    		|	НоменклатураКонтрагентов.Артикул КАК Артикул,
    		|	НоменклатураКонтрагентов.Штрихкод КАК Штрихкод,
    		|	НоменклатураКонтрагентов.Наименование КАК Наименование,
    		|	НоменклатураКонтрагентов.СтавкаНДС КАК ШК_короб,
    		|	НоменклатураКонтрагентов.ЕдиницаИзмеренияКод КАК ПечататьЕАНнаБатон
    		|ИЗ
    		|	РегистрСведений.НоменклатураКонтрагентовБЭД КАК НоменклатураКонтрагентов
    		|ГДЕ
    		|	НоменклатураКонтрагентов.Номенклатура = &Номенклатура
    		|	И НоменклатураКонтрагентов.Владелец = &Владелец";

    PoKoleno, 02 Октября 2020

    Комментарии (5)
  7. 1C / Говнокод #26995

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    	
    	Если Данные.Свойство("Ссылка") И ЗначениеЗаполнено(Данные.Ссылка) Тогда
    		СтандартнаяОбработка = Ложь;
    		Представление = Данные.Ссылка.Наименование;
    	КонецЕсли; 
    	
    КонецПроцедуры

    У ребят не заладилось с этой процедурой. Смысла в этих действиях 0. Объект справочник.

    NioGoth, 01 Октября 2020

    Комментарии (24)
  8. 1C / Говнокод #26994

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    Процедура ОбработкаПолученияПредставления(Данные, Представление, СтандартнаяОбработка)
    	СтандартнаяОбработка=Ложь;
    	Представление="";
    	Для Каждого Стр Из Данные.Ссылка.Состав Цикл
    		Представление=Представление+?(Представление="","",", ")+Стр.Автомобиль;
    		Если СтрДлина(Представление)>50 Тогда 
    			Представление=Представление+"...";
    			Прервать
    		КонецЕсли;
    	КонецЦикла;
    	//Представление=""+Данные.Ссылка.Клиент+" ("+Представление+")";
    КонецПроцедуры

    А чё это списки у нас вдруг тормозить стали?

    NioGoth, 01 Октября 2020

    Комментарии (1)
  9. 1C / Говнокод #26831

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    Запрос = Новый Запрос;
    	Запрос.Текст = "ВЫБРАТЬ
    	|	БИТ_Отель_ДоговорыЭквайринга.Ссылка
    	|ИЗ
    	|	Справочник.БИТ_Отель_ДоговорыЭквайринга КАК БИТ_Отель_ДоговорыЭквайринга
    	|ГДЕ
    	|	БИТ_Отель_ДоговорыЭквайринга.ДоговорВзаиморасчетов = &ДоговорВзаиморасчетов";
    	
    	Запрос.УстановитьПараметр("ДоговорВзаиморасчетов", СтруктураПарам.БИТ_Отель_ДоговорЭквайринга.ДоговорВзаиморасчетов);
    	
    	Результат = Запрос.Выполнить().Выгрузить();
    	
    	Струк = Новый Структура;
    	Струк.Вставить("ВидОплаты", ВидОплаты);
    	
    	Если Результат.Количество() Тогда
    		РезОтбора =	Результат[0].Ссылка.ТарифыЗаРасчетноеОбслуживание.НайтиСтроки(Струк);
    		Если РезОтбора.Количество() Тогда
    			ПроцентТорговойУступки = РезОтбора[0].ПроцентТорговойУступки;
    		Иначе
    			ПроцентТорговойУступки = 0;
    			Предупреждение("Не указан процент торговой уступки!");
    			ЭлементыФормы.ПанельДокумента.ТекущаяСтраница = ЭлементыФормы.ПанельДокумента.Страницы.Эквайринг;
    			ЭлементыФормы.ПроцентТорговойУступки.ОтметкаНезаполненного = Истина;
    			ЭлементыФормы.СуммаТорговойУступки.ОтметкаНезаполненного = Истина;
    			ТекущийЭлемент = ЭлементыФормы.ПроцентТорговойУступки;
    		КонецЕсли;
    	Иначе
    		ПроцентТорговойУступки = 0;
    		Предупреждение("Не указан процент торговой уступки!");
    		ЭлементыФормы.ПанельДокумента.ТекущаяСтраница = ЭлементыФормы.ПанельДокумента.Страницы.Эквайринг;
    		ЭлементыФормы.ПроцентТорговойУступки.ОтметкаНезаполненного = Истина;
    		ЭлементыФормы.СуммаТорговойУступки.ОтметкаНезаполненного = Истина;
    		ТекущийЭлемент = ЭлементыФормы.ПроцентТорговойУступки;
    	КонецЕсли;

    уже шестой год я работаю с этой "конфой", жаль что ее целиком нельзя сюда выложить, там, не считая исходной бух части, сплошной креатив каких то ДЦП на обеденной перемене классе во втором.

    jah, 31 Июля 2020

    Комментарии (50)
  10. 1C / Говнокод #26813

    +3

    1. 1
    2. 2
    3. 3
    4. 4
    ГрИнвС = ?(ГрИнвЧ=1, "Первая", ?(ГрИнвЧ=2, "Вторая", ?(ГрИнвЧ=3, "Третья", 
             ?(ГрИнвЧ=4, "Четвертая", ?(ГрИнвЧ=5, "Пятая", ?(ГрИнвЧ=6, "Шестая",
    	 ?(ГрИнвЧ=7, "Седьмая", ?(ГрИнвЧ=8, "Восьмая", ?(ГрИнвЧ=9, "Девятая", 
    	   Строка(ГрИнвЧ))))))))));

    Определение группы инвалидности из числового значения. Возможно, код писал обладатель неизвестной медицине 9-й группы инвалидности.

    maalssy, 23 Июля 2020

    Комментарии (43)