1. 1C / Говнокод #25178

    −5

    1. 1
    EFG тред иди.

    Тред в котором мы пишим реквесты и пожелания EFG.
    EFG, прикрути живое обновление через вебсокеты, переделай фронт уже с этого древнего говна, на модное SPA, прикрути нейросеточку и блокчейн.

    хуита, 11 Декабря 2018

    Комментарии (24)
  2. 1C / Говнокод #25164

    −2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
    	//...
    	Если НЕ Отказ Тогда
    		
    		ЭтотОбъект.ОбменДанными.Загрузка = Истина;
    		ЭтотОбъект.Записать();
    		ЭтотОбъект.ОбменДанными.Загрузка = Ложь;
    		//...
    	КонецЕсли; 	
    	
    КонецПроцедуры // ПередЗаписью

    БУдУ, УТПдУ, УППдУ
    Бля, ну как так можно? Что за идиот это писал?
    Сначала Пактум от школьника, теперь эта херь...

    Asaharu, 07 Декабря 2018

    Комментарии (6)
  3. 1C / Говнокод #25161

    0

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    процедура расш_таблицаприактивациистроки(элемент)
    простодеревозначений = новый деревозначений;
    простодеревозначений.очистить();
    конецпроцедуры
    //впадает в рекурсию и программа умирает
    
    процедура расш_таблицаприактивациистроки_(элемент)
    простодеревозначений = новый таблицазначений;
    простодеревозначений.очистить();
    конецпроцедуры
    //не впадает в рекурсию

    Чо поцоны, изи рекурсия. УТ 11. Насчет других не тестил.
    При активации строки ТЧ, срабатывает эта процедура. Создаю новое дерево значений, и при его очистки вызывается какой-то общий модуль который я не звал и начинает активировать всю форму - охуенно. соответственно вызывается эта процедура пофторно. При ТЗ такой хуйни нет.

    3oJIoTou_xyu, 06 Декабря 2018

    Комментарии (6)
  4. 1C / Говнокод #25096

    −2

    1. 1
    2. 2
    ТекстОшибки = НСтр("ru='Клиенту ""%Партнер%"" запрещена отгрузка.'");
    ТекстОшибки = СтрЗаменить(ТекстОшибки, "%Партнер%", Партнер);

    Когда платят за количество строчек, а не смысл. Ебала жаба гадюку просто.

    ChoaNyan, 19 Ноября 2018

    Комментарии (1)
  5. 1C / Говнокод #25093

    +1

    1. 1
    Выб = выбратьизсписка(элемент.списоквыбора,элемент);

    СИДЕЛ НАД ЭТОЙ ХУЕТОЙ ДЖВА ЧАСА, И НЕ ПОНИМАЛ ПОЧЕМУ ЭТОТ КУСОК НЕОТРАБАТЫВАЛ И ВОЗВРАЩАЛ НЕОПРЕДЕЛЕНО И СРАЗУ ЖЕ ПРОСКАКИВАЛ ДАЛЬШЕ. ХОТЯ ЭЛЕМЕНТ И СПИСОК ЕСТЬ, ПОИДЕИ ДОЛЖЕН БЫЛ ПОВЫСНУТЬ В ОЖИДАНИИ ПОКА ПОЛЬЗОВАТЕЛЬ ВЫБЕРЕТ ИЗ НЕГО ЗНАЧЕНИЕ.

    ОКАЗАЛОСЬ. ОТЛАДЧИК... РЕШИЛ ВЫЗЫВАТЬ САМ СЕБЕ ЭТОТ СПИСОК И САМ ПО СЕБЕ НИХУЯ НЕ ВЫБИРАТЬ.

    TOPT, 19 Ноября 2018

    Комментарии (8)
  6. 1C / Говнокод #25089

    −1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    Функция ПолучитьСтавкуНДС(СтавкаНДС) Экспорт
    
    	Если СтавкаНДС = Перечисления.СтавкиНДС.НДС20 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС20_120 Тогда
    		Возврат 20;
    	ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС10 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС10_110 Тогда
    		Возврат 10;
    	ИначеЕсли СтавкаНДС = Перечисления.СтавкиНДС.НДС18 ИЛИ СтавкаНДС = Перечисления.СтавкиНДС.НДС18_118 Тогда
    		Возврат 18;
    	КонецЕсли;
    
    	Возврат 0;
    
    КонецФункции

    Банально.
    Рарус.

    3oJIoTou_xyu, 16 Ноября 2018

    Комментарии (54)
  7. 1C / Говнокод #24935

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    Писал значит обмен ну там по http запросами и прочим говном на 1С между сайтом на битриксе и самой базой.
    Сидел и думал, каким форматом обмениваться
    Эти ссаные phpшники из центральной россии предлагали JSON и CSV.
    А я подумал, и подумал что не хочу слишком банально. Написал сериализацию с 1С в lua, и обмениваюсь lua.
    эти phpшные хуйни в шоке, ведь у них нет такого десериализатора. Жду от них результата уже джва года.

    ух какой я злодей.

    3oJIoTou_xyu, 18 Октября 2018

    Комментарии (32)
  8. 1C / Говнокод #24860

    −10

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    9. 9
    Процедура тпТоварыПриПолученииДанных(Элемент, ОформленияСтрок)
    	Модифицированность_ = Модифицированность;
    	Для Каждого Стр из ОформленияСтрок Цикл
    		Если НЕ Стр.ДанныеСтроки.Вес = 0 И НЕ Стр.ДанныеСтроки.ПроцентУсушки = 0 Тогда			
    			Стр.ДанныеСтроки.Усушка = (Стр.ДанныеСтроки.Вес * Стр.ДанныеСтроки.ПроцентУсушки / 100) * Стр.ДанныеСтроки.Количество;									
    		КонецЕсли;
    	КонецЦикла;
    	Модифицированность = Модифицированность_;
    КонецПроцедуры

    Данные табличной части модифицируются в процедуре ПриПолученииДанных (видимо, лучшего места для этого не нашлось), что закономерно приводит к отложенному на мгновение вызову ПриПолученииДанных ещё раз, и ещё, и так далее. В результате процессор загружается почти на 100%, значок * в заголовке формы дико мерцает.
    Написано программистом с 6-значной ЗП.

    strashny_programmist, 04 Октября 2018

    Комментарии (15)
  9. 1C / Говнокод #24852

    −1

    1. 1
    2. 2
    |			И (ПериодическийРегистрСведенийПриход.ВидДвижения = ЗНАЧЕНИЕ(Перечисление.ОРГ_ВидыДвижений.Приход))
    |			И (ПериодическийРегистрСведений.ВидДвижения = ЗНАЧЕНИЕ(Перечисление.ОРГ_ВидыДвижений.Расход))

    Регистр накопления? Не, это не для нас.

    Vukhdjaaz, 03 Октября 2018

    Комментарии (16)
  10. 1C / Говнокод #24776

    −5

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Если ПаузаСек=5 Тогда
    	//Задержка введена специально, так как нужно подождать бизнес процесс и задачи перейдут в новое состояние 
    	СУУ_УниверсальныеСервер.Пауза(5);
    
    ИначеЕсли ПаузаСек=0 Тогда	
    	//Не ждем
    
    Иначе
    	СУУ_УниверсальныеСервер.Пауза(ПаузаСек);
    
    КонецЕсли;

    5xABdAy, 17 Сентября 2018

    Комментарии (16)