1. 1C / Говнокод #24576

    +2

    1. 1
    https://s22.postimg.cc/5zky9jn1t/Image_from_i_OS.jpg

    roskomgovno, 03 Августа 2018

    Комментарии (6)
  2. 1C / Говнокод #24509

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    Попытка
    
       Если Найти( ОформлениеСтроки.ДанныеСтроки.Загружен, Истина ) Тогда
          // раскраска строки
       КонецЕсли;
    
    Исключение
    КонецПопытки

    На первый взгляд возникает вопрос: WTF???7семь
    На десятый взгляд меня посетили сомненья, ведь код а) рабочий, и 2) гениален!
    Смотрите сами.

    Вместо "Если ОформлениеСтроки.ДанныеСтроки.Загружен Тогда"

    гений с большой буквы "Г" делает финт ушами с наподвыподвертом:
    Так как функция "Найти" работает со строками и 1С автоматически преобразует, где возможно, типы, булево значение ОформлениеСтроки.ДанныеСтроки.Загружен приводится к строке, равной "Истина" или "Ложь". Второй аргумент также приводится к строке, равной "Истина". Далее функция "Найти" выполняет поиск подстроки (аргумент №2) в строке (аргумент №1) и возвращает позицию найденной подстроки, в результате имеем 1 если ОформлениеСтроки.ДанныеСтроки.Загружен = Истина, или 0 в противном случае.
    Получается

    Если 1 Тогда....
    или
    Если 0 Тогда....

    где 1 или 0 автоматически приводится 1Ской к типу булево, где Булево(1) = Истина, и Булево(0) = Ложь.

    ИГОГО:
    Условие выполняется, а гений с большой буквы "Г"... пугает меня, если честно, одним своим существованием о_О

    whiledoman, 17 Июля 2018

    Комментарии (3)
  3. 1C / Говнокод #24465

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    32. 32
    33. 33
    34. 34
    35. 35
    36. 36
    37. 37
    38. 38
    39. 39
    40. 40
    41. 41
    42. 42
    43. 43
    44. 44
    45. 45
    46. 46
    47. 47
    48. 48
    49. 49
    50. 50
    ВЫБРАТЬ
    	ПоступлениеТоваровУслуг.Ссылка,
    	ПоступлениеТоваровУслуг.Дата,
    	ПоступлениеТоваровУслуг.Контрагент,
    	ПоступлениеТоваровУслуг.Организация,
    	ДополнительныеСведения.Значение КАК ДатаВозврата
    ПОМЕСТИТЬ втДокументы
    ИЗ
    	Документ.ПоступлениеТоваровУслуг КАК ПоступлениеТоваровУслуг
    		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
    		ПО ПоступлениеТоваровУслуг.Ссылка = ДополнительныеСведения.Объект
    ГДЕ
    	ДополнительныеСведения.Значение ЕСТЬ NULL
    
    ОБЪЕДИНИТЬ ВСЕ
    
    ВЫБРАТЬ
    	ПоступлениеУслугПрочихАктивов.Ссылка,
    	ПоступлениеУслугПрочихАктивов.Дата,
    	ПоступлениеУслугПрочихАктивов.Контрагент,
    	ПоступлениеУслугПрочихАктивов.Организация,
    	ДополнительныеСведения.Значение
    ИЗ
    	Документ.ПоступлениеУслугПрочихАктивов КАК ПоступлениеУслугПрочихАктивов
    		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ДополнительныеСведения КАК ДополнительныеСведения
    		ПО ПоступлениеУслугПрочихАктивов.Ссылка = ДополнительныеСведения.Объект
    ГДЕ
    	ДополнительныеСведения.Значение ЕСТЬ NULL
    ;
    
    ////////////////////////////////////////////////////////////////////////////////
    ВЫБРАТЬ
    	втДокументы.Ссылка КАК Ссылка,
    	втДокументы.Дата КАК Дата,
    	втДокументы.Контрагент,
    	втДокументы.Организация,
    	втДокументы.ДатаВозврата
    ИЗ
    	втДокументы КАК втДокументы
    ГДЕ
    	втДокументы.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания
    	И втДокументы.Ссылка.Проведен
    	И втДокументы.ДатаВозврата ЕСТЬ NULL
    {ГДЕ
    	втДокументы.Контрагент.*,
    	втДокументы.Организация.*}
    
    УПОРЯДОЧИТЬ ПО
    	Дата,
    	Ссылка

    Охуительная оптимизация запроса временными таблицами, а ведь на первый взгляд даже не говнокод

    ChoaNyan, 10 Июля 2018

    Комментарии (1)
  4. 1C / Говнокод #24426

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    Если Найти(_оинв.Комментарий,"#инвентаризация гсм#")=0 Тогда
    		_оинв.Комментарий="#инвентаризация гсм#";
    		Если не Найти(_комментарий,"газ")=0 Тогда
    			_оинв.Комментарий=_оинв.Комментарий+" газ";
    		ИначеЕсли не Найти(_оинв.Склад.Наименование,"АГЗС")=0 Тогда
    			_оинв.Комментарий=_оинв.Комментарий+" газ";
    		КонецЕсли;
    		_оинв.Комментарий=_оинв.Комментарий+" "+_комментарий;
    	ИначеЕсли не Найти(_оинв.Склад.Наименование,"АГЗС")=0 Тогда
    		Если Найти(_комментарий,"газ")=0 Тогда
    			_оинв.Комментарий=_оинв.Комментарий+" газ";
    		ИначеЕсли не Найти(_комментарий," газ газ")=0 Тогда
    			_оинв.Комментарий=СтрЗаменить(_оинв.Комментарий," газ газ"," газ");
    		КонецЕсли;
    	КонецЕсли;

    Где "_оинв" это ДокументОбъект Инвентаризация

    MyNameIs, 29 Июня 2018

    Комментарии (6)
  5. 1C / Говнокод #24385

    +2

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    Если (Строка(Объект.ДатаНач) = "01.01.0001 0:00:00") или (Строка(Объект.ДатаКон) = "01.01.0001 0:00:00") Тогда
      ТекстСообщения = НСтр("ru = 'Задайте период формирования отчета!
      |Должны быть заполнены дата начала и дата окончания периода.'");
      Предупреждение(ТекстСообщения);
      Возврат;
     КонецЕсли;

    Проверка даты от лучшего программиста организации с ЗП 100k р

    AlexZ1978, 15 Июня 2018

    Комментарии (11)
  6. 1C / Говнокод #24240

    +2

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    Функция СоздатьМассив // Экспорт, 29 параметров
    (
    	Значение01 = '05710422152926',
    	Значение02 = '05710422152926',
    	Значение03 = '05710422152926',
    	Значение04 = '05710422152926',
    	Значение05 = '05710422152926',
    	Значение06 = '05710422152926',
    	Значение07 = '05710422152926',
    	Значение08 = '05710422152926',
    	Значение09 = '05710422152926',
    	Значение10 = '05710422152926',
    	Значение11 = '05710422152926',
    	Значение12 = '05710422152926',
    	Значение13 = '05710422152926',
    	Значение14 = '05710422152926',
    	Значение15 = '05710422152926',
    	Значение16 = '05710422152926',
    	Значение17 = '05710422152926',
    	Значение18 = '05710422152926',
    	Значение19 = '05710422152926',
    	Значение20 = '05710422152926',
    	Значение21 = '05710422152926',
    	Значение22 = '05710422152926',
    	Значение23 = '05710422152926',
    	Значение24 = '05710422152926',
    	Значение25 = '05710422152926',
    	Значение26 = '05710422152926',
    	Значение27 = '05710422152926',
    	Значение28 = '05710422152926',
    	Значение29 = '05710422152926'
    )
    Экспорт
    	
    	Нил_ = '05710422152926'; // Предположительная дата рождения пророка Мухаммеда
    	
    	Если Нил_ = Значение02 Тогда
    		Если Нил_ = Значение01 Тогда
    			Массив_ = Новый Массив;
    			Перейти ~Метка00;
    		Иначе
    			Массив_ = Новый Массив(1);
    			Перейти ~Метка01;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение06 Тогда
    		Если Нил_ = Значение04 Тогда
    			Если Нил_ = Значение03 Тогда
    				Массив_ = Новый Массив(2);
    				Перейти ~Метка02;
    			Иначе
    				Массив_ = Новый Массив(3);
    				Перейти ~Метка03;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение05 Тогда
    			Массив_ = Новый Массив(4);
    			Перейти ~Метка04;
    		Иначе
    			Массив_ = Новый Массив(5);
    			Перейти ~Метка05;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение14 Тогда
    		Если Нил_ = Значение10 Тогда
    			Если Нил_ = Значение08 Тогда
    				Если Нил_ = Значение07 Тогда
    					Массив_ = Новый Массив(6);
    					Перейти ~Метка06;
    				Иначе
    					Массив_ = Новый Массив(7);
    					Перейти ~Метка07;
    				КонецЕсли;
    			ИначеЕсли Нил_ = Значение09 Тогда
    				Массив_ = Новый Массив(8);
    				Перейти ~Метка08;
    			Иначе
    				Массив_ = Новый Массив(9);
    				Перейти ~Метка09;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение12 Тогда
    			Если Нил_ = Значение11 Тогда
    				Массив_ = Новый Массив(10);
    				Перейти ~Метка10;
    			Иначе
    				Массив_ = Новый Массив(11);
    				Перейти ~Метка11;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение13 Тогда
    			Массив_ = Новый Массив(12);
    			Перейти ~Метка12;
    		Иначе
    			Массив_ = Новый Массив(13);
    			Перейти ~Метка13;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение22 Тогда
    		Если Нил_ = Значение18 Тогда
    			Если Нил_ = Значение16 Тогда
    				Если Нил_ = Значение15 Тогда
    					Массив_ = Новый Массив(14);
    					Перейти ~Метка14;
    				Иначе
    					Массив_ = Новый Массив(15);

    1С Медицина: Больничные
    Халяль

    elizir, 09 Мая 2018

    Комментарии (6)
  7. 1C / Говнокод #24225

    −3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    http://developer.android.com/
    Заблокировано в РФ
    
    http://isitblockedinrussia.ru/?host=http%3A%2F%2Fdeveloper.android.com%2F
    
    http://addons.mozilla.org 
    Заблокировано в РФ
    http://isitblockedinrussia.ru/?host=http%3A%2F%2Faddons.mozilla.org%20

    ж)

    roskomgovno, 04 Мая 2018

    Комментарии (40)
  8. 1C / Говнокод #24224

    +4

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    //Модуль 1
    Функция хуй() экспорт
    возврат хуйбазовый();
    конецфункции
    
    //Модуль 2
    Функция хуйбазовый() экспорт
    возврат хуйразширеный();
    конецфункции
    
    //Модуль 3
    Функция хуйстандартный() экспорт
    возврат хуйособый();
    конецфункции
    
    //Модуль 4
    Функция хуйособый() экспорт
    возврат хуйуправляемый();
    конецфункции
    
    //Модуль 5
    Функция хуйуправляемый() экспорт
    возврат получитьхуй();
    конецфункции
    
    //Модуль 6
    Функция получитьхуй() экспорт
    возврат хуйстандарт();
    конецфункции
    
    и т.д.

    Нахуя?

    3oJIoTou_xyu, 04 Мая 2018

    Комментарии (19)
  9. 1C / Говнокод #24058

    +4

    1. 1
    2. 2
    //// ВРЕМЕННО!!! НАКОСЯЧЕНО С ПЕРИОДАМИ!!! ЧТОБЫ РАБОТАЛО ДЕЛАЕМ СРЕЗ НА КОНЕЦ МЕСЯЦА
    //// НУЖНО ПЕРЕДЕЛЫВАТЬ ЗАПРОС

    Временно, оно же и навсегда.

    ah2, 02 Апреля 2018

    Комментарии (2)
  10. 1C / Говнокод #24057

    0

    1. 1
    //Процедура АНуКаДавайКаПлясатьВыходи(...) Экспорт

    ah2, 02 Апреля 2018

    Комментарии (4)