1. 1C / Говнокод #24240

    0

    1. 001
    2. 002
    3. 003
    4. 004
    5. 005
    6. 006
    7. 007
    8. 008
    9. 009
    10. 010
    11. 011
    12. 012
    13. 013
    14. 014
    15. 015
    16. 016
    17. 017
    18. 018
    19. 019
    20. 020
    21. 021
    22. 022
    23. 023
    24. 024
    25. 025
    26. 026
    27. 027
    28. 028
    29. 029
    30. 030
    31. 031
    32. 032
    33. 033
    34. 034
    35. 035
    36. 036
    37. 037
    38. 038
    39. 039
    40. 040
    41. 041
    42. 042
    43. 043
    44. 044
    45. 045
    46. 046
    47. 047
    48. 048
    49. 049
    50. 050
    51. 051
    52. 052
    53. 053
    54. 054
    55. 055
    56. 056
    57. 057
    58. 058
    59. 059
    60. 060
    61. 061
    62. 062
    63. 063
    64. 064
    65. 065
    66. 066
    67. 067
    68. 068
    69. 069
    70. 070
    71. 071
    72. 072
    73. 073
    74. 074
    75. 075
    76. 076
    77. 077
    78. 078
    79. 079
    80. 080
    81. 081
    82. 082
    83. 083
    84. 084
    85. 085
    86. 086
    87. 087
    88. 088
    89. 089
    90. 090
    91. 091
    92. 092
    93. 093
    94. 094
    95. 095
    96. 096
    97. 097
    98. 098
    99. 099
    100. 100
    Функция СоздатьМассив // Экспорт, 29 параметров
    (
    	Значение01 = '05710422152926',
    	Значение02 = '05710422152926',
    	Значение03 = '05710422152926',
    	Значение04 = '05710422152926',
    	Значение05 = '05710422152926',
    	Значение06 = '05710422152926',
    	Значение07 = '05710422152926',
    	Значение08 = '05710422152926',
    	Значение09 = '05710422152926',
    	Значение10 = '05710422152926',
    	Значение11 = '05710422152926',
    	Значение12 = '05710422152926',
    	Значение13 = '05710422152926',
    	Значение14 = '05710422152926',
    	Значение15 = '05710422152926',
    	Значение16 = '05710422152926',
    	Значение17 = '05710422152926',
    	Значение18 = '05710422152926',
    	Значение19 = '05710422152926',
    	Значение20 = '05710422152926',
    	Значение21 = '05710422152926',
    	Значение22 = '05710422152926',
    	Значение23 = '05710422152926',
    	Значение24 = '05710422152926',
    	Значение25 = '05710422152926',
    	Значение26 = '05710422152926',
    	Значение27 = '05710422152926',
    	Значение28 = '05710422152926',
    	Значение29 = '05710422152926'
    )
    Экспорт
    	
    	Нил_ = '05710422152926'; // Предположительная дата рождения пророка Мухаммеда
    	
    	Если Нил_ = Значение02 Тогда
    		Если Нил_ = Значение01 Тогда
    			Массив_ = Новый Массив;
    			Перейти ~Метка00;
    		Иначе
    			Массив_ = Новый Массив(1);
    			Перейти ~Метка01;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение06 Тогда
    		Если Нил_ = Значение04 Тогда
    			Если Нил_ = Значение03 Тогда
    				Массив_ = Новый Массив(2);
    				Перейти ~Метка02;
    			Иначе
    				Массив_ = Новый Массив(3);
    				Перейти ~Метка03;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение05 Тогда
    			Массив_ = Новый Массив(4);
    			Перейти ~Метка04;
    		Иначе
    			Массив_ = Новый Массив(5);
    			Перейти ~Метка05;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение14 Тогда
    		Если Нил_ = Значение10 Тогда
    			Если Нил_ = Значение08 Тогда
    				Если Нил_ = Значение07 Тогда
    					Массив_ = Новый Массив(6);
    					Перейти ~Метка06;
    				Иначе
    					Массив_ = Новый Массив(7);
    					Перейти ~Метка07;
    				КонецЕсли;
    			ИначеЕсли Нил_ = Значение09 Тогда
    				Массив_ = Новый Массив(8);
    				Перейти ~Метка08;
    			Иначе
    				Массив_ = Новый Массив(9);
    				Перейти ~Метка09;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение12 Тогда
    			Если Нил_ = Значение11 Тогда
    				Массив_ = Новый Массив(10);
    				Перейти ~Метка10;
    			Иначе
    				Массив_ = Новый Массив(11);
    				Перейти ~Метка11;
    			КонецЕсли;
    		ИначеЕсли Нил_ = Значение13 Тогда
    			Массив_ = Новый Массив(12);
    			Перейти ~Метка12;
    		Иначе
    			Массив_ = Новый Массив(13);
    			Перейти ~Метка13;
    		КонецЕсли;
    	ИначеЕсли Нил_ = Значение22 Тогда
    		Если Нил_ = Значение18 Тогда
    			Если Нил_ = Значение16 Тогда
    				Если Нил_ = Значение15 Тогда
    					Массив_ = Новый Массив(14);
    					Перейти ~Метка14;
    				Иначе
    					Массив_ = Новый Массив(15);

    1С Медицина: Больничные
    Халяль

    elizir, 09 Мая 2018

    Комментарии (3)
  2. 1C / Говнокод #24225

    −3

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    7. 7
    8. 8
    http://developer.android.com/
    Заблокировано в РФ
    
    http://isitblockedinrussia.ru/?host=http%3A%2F%2Fdeveloper.android.com%2F
    
    http://addons.mozilla.org 
    Заблокировано в РФ
    http://isitblockedinrussia.ru/?host=http%3A%2F%2Faddons.mozilla.org%20

    ж)

    roskomgovno, 04 Мая 2018

    Комментарии (39)
  3. 1C / Говнокод #24224

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    13. 13
    14. 14
    15. 15
    16. 16
    17. 17
    18. 18
    19. 19
    20. 20
    21. 21
    22. 22
    23. 23
    24. 24
    25. 25
    26. 26
    27. 27
    28. 28
    29. 29
    30. 30
    31. 31
    //Модуль 1
    Функция хуй() экспорт
    возврат хуйбазовый();
    конецфункции
    
    //Модуль 2
    Функция хуйбазовый() экспорт
    возврат хуйразширеный();
    конецфункции
    
    //Модуль 3
    Функция хуйстандартный() экспорт
    возврат хуйособый();
    конецфункции
    
    //Модуль 4
    Функция хуйособый() экспорт
    возврат хуйуправляемый();
    конецфункции
    
    //Модуль 5
    Функция хуйуправляемый() экспорт
    возврат получитьхуй();
    конецфункции
    
    //Модуль 6
    Функция получитьхуй() экспорт
    возврат хуйстандарт();
    конецфункции
    
    и т.д.

    Нахуя?

    3oJIoTou_xyu, 04 Мая 2018

    Комментарии (9)
  4. 1C / Говнокод #24058

    +3

    1. 1
    2. 2
    //// ВРЕМЕННО!!! НАКОСЯЧЕНО С ПЕРИОДАМИ!!! ЧТОБЫ РАБОТАЛО ДЕЛАЕМ СРЕЗ НА КОНЕЦ МЕСЯЦА
    //// НУЖНО ПЕРЕДЕЛЫВАТЬ ЗАПРОС

    Временно, оно же и навсегда.

    ah2, 02 Апреля 2018

    Комментарии (1)
  5. 1C / Говнокод #24057

    0

    1. 1
    //Процедура АНуКаДавайКаПлясатьВыходи(...) Экспорт

    ah2, 02 Апреля 2018

    Комментарии (4)
  6. 1C / Говнокод #24036

    −2

    1. 1
    строкаР.сумма =(-1)*строкаР.сумма;

    "строкаР.сумма" всегда является числом

    naodesu, 30 Марта 2018

    Комментарии (17)
  7. 1C / Говнокод #23976

    +1

    1. 1
    2. 2
    3. 3
    4. 4
    Если Не ЗначениеЗаполнено(ДатаПриемаСотрудника) Тогда
    		Возврат 0;
    		Предупреждение("У сотрудника "+Сотрудник+" нет даты приема проведите прием на работу");
    	КонецЕсли;

    еее анричабол стейтментс

    sgo, 21 Марта 2018

    Комментарии (13)
  8. 1C / Говнокод #23723

    +1

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка)
    	
    	Организация1 = Справочники.Организации.ПустаяСсылка();
    	Организация1 = Справочники.Организации.НайтиПоНаименованию("ХХХХХ Андрей Александрович ИП");
    	Организация = Организация1;
    	ОрганизацияШапка = Организация1;
    	Склад = Справочники.Склады.НайтиПоНаименованию("Сервис центр");
    	Контрагент = Справочники.Партнеры.НайтиПоНаименованию("Розничный покупатель");
    	ВидОперации = Перечисления.ВидРемонта.ПлатныйРемонт;
    	
    КонецПроцедуры;

    Строка 3. Непонятно для чего введена переменная Организация1 (реквизита такого нет).
    Строка 3. Непонятно для чего нужна инициализация пустой ссылкой, если в следующей строке происходит присваивание другого значения.
    Строка5. Почему бы сразу не инициализировать реквизит нужным значением?

    VladC, 12 Февраля 2018

    Комментарии (2)
  9. 1C / Говнокод #23714

    0

    1. 1
    2. 2
    3. 3
    4. 4
    5. 5
    6. 6
    //Текстовый реквизит 
    //Событие реквизита формы НП_ТелефонПолучателя  (Строка (50)) - очистка
    
    Процедура НП_ТелефонПолучателяОчистка(Элемент, СтандартнаяОбработка)
    	НП_ТелефонПолучателя = "";
    КонецПроцедуры

    Ну чтоб уж точно очистить

    FesenkoA, 07 Февраля 2018

    Комментарии (0)
  10. 1C / Говнокод #23713

    +2

    1. 01
    2. 02
    3. 03
    4. 04
    5. 05
    6. 06
    7. 07
    8. 08
    9. 09
    10. 10
    11. 11
    12. 12
    Запрос = Новый Запрос;
    	Запрос.Текст="ВЫБРАТЬ
    	|	ЗаказНаряд.Ссылка КАК Ссылка
    	|ИЗ
    	|	Документ.ЗаказНаряд КАК ЗаказНаряд
    	|ГДЕ
    	|	ЗаказНаряд.Проведен = ИСТИНА";	
    
    	Выборка=Запрос.Выполнить().Выбрать();
    	Выборка.Следующий();
    	Если обЗначениеНеЗаполнено(Выборка.Ссылка) Тогда
    .......

    Чуть упростил запрос для быстроты понимания...
    Как проверить запрос ПУСТОЙ() или нет... Вот один из разработчиков нашел метод.....

    timofeysin, 07 Февраля 2018

    Комментарии (8)